SC Workbook
科目 A-2 · セキュリティ

偽の RA による中間者攻撃

IPv6 を利用している社内 LAN で,複数の PC の通信が,同じセグメントに接続された持込み端末 X を経由していたことが分かった。各 PC は IPv6 アドレスとデフォルトルータを自動設定しており,DHCPv6 は使用していない。調査の結果,各 PC のデフォルトルータのアドレスが,正規のルータのリンクローカルアドレスではなく,X のリンクローカルアドレスになっていた。原因と対策の組合せとして,最も適切なものはどれか。

  1. アX が偽の DHCPv6 サーバとして応答し,デフォルトルータを配布した。L2 スイッチの DHCP スヌーピングで,信頼するポート以外からの DHCPv6 サーバの応答を破棄する。
  2. イX が偽の RA を送信し,各 PC がその送信元アドレスをデフォルトルータとして設定した。L2 スイッチで,正規のルータを接続したポート以外から受信した RA を破棄する。
  3. ウX が,正規のルータのアドレスに自分の MAC アドレスを対応付ける偽の近隣広告を送信した。PC に正規のルータの MAC アドレスを静的に登録する。
  4. エX がルータ要請(RS)を大量に送信し,正規のルータが RA を送れなくなった。L2 スイッチで RS の転送量を制限する。
正解と解説を見る

正解 イ

この問題の基礎知識

  • IPv6 の近隣探索(NDP)は ICMPv6 で行い,端末がルータに RA の送信を求めるルータ要請(RS),ルータが自身の存在やプレフィックスを通知するルータ広告(RA),アドレス解決に使う近隣要請(NS)と近隣広告(NA)などがある。
  • IPv6 の端末は,RA で通知されたプレフィックスからアドレスを自動設定でき,RA の送信元のリンクローカルアドレスをデフォルトルータとして設定する。
  • DHCPv6 はアドレスや DNS サーバの情報などを配布できるが,標準のオプションにはデフォルトルータを配布するものがなく,デフォルトルータの設定には RA が使われる。
  • 偽の NA による攻撃は,IP アドレスに対応するリンク層アドレスを書き換えるもので,IPv4 の ARP スプーフィングに相当し,宛先の IP アドレス自体は変わらない。
アX が偽の DHCPv6 サーバとして応答し,デフォルトルータを配布した。L2 スイッチの DHCP スヌーピングで,信頼するポート以外からの DHCPv6 サーバの応答を破棄する。

各 PC は DHCPv6 を使用していないので,偽の DHCPv6 サーバの応答は設定に使われない。IPv6 のデフォルトルータは DHCPv6 ではなく RA によって設定されるので,DHCP スヌーピングではこの事象を防げない。

イX が偽の RA を送信し,各 PC がその送信元アドレスをデフォルトルータとして設定した。L2 スイッチで,正規のルータを接続したポート以外から受信した RA を破棄する。正解

IPv6 の端末は RA の送信元アドレスをデフォルトルータとして使うので,偽の RA を受けた PC の通信は X を経由し,中間者攻撃が可能になる。RA ガードは,L2 スイッチで RA の受信を許可したポート以外からの RA を遮断する。

ウX が,正規のルータのアドレスに自分の MAC アドレスを対応付ける偽の近隣広告を送信した。PC に正規のルータの MAC アドレスを静的に登録する。

偽の近隣広告(NA)による攻撃では,デフォルトルータのアドレスは正規のルータのままで,対応する MAC アドレスが X のものに置き換わる。デフォルトルータのアドレス自体が X のものに変わっていた今回の事象とは合わない。

エX がルータ要請(RS)を大量に送信し,正規のルータが RA を送れなくなった。L2 スイッチで RS の転送量を制限する。

RS は端末がルータに RA の送信を求めるメッセージであり,大量に送っても,ほかの PC が X をデフォルトルータとして設定することはない。PC に X をデフォルトルータとして設定させるには,X 自身が RA を送る必要がある。

検証用の出典出典照合済み
RFC 6104 Rogue IPv6 Router Advertisement Problem Statement / RFC 6105 IPv6 Router Advertisement Guard / RFC 4861 Neighbor Discovery for IP version 6 (IPv6)
照合の根拠(6 件)
  • イ(正解)・エ: デフォルトルータのアドレスは RA の送信元アドレスから取られるので,X のリンクローカルアドレスが設定されたのは X が RA を送ったため
    the default router address is drawn directly from the source address of the RA message.
    RFC 6104 · Section 1(新しいタブで開きます)
  • イ(正解): 偽のルータに通信が集まり,盗聴・改ざん(中間者攻撃)が可能になる
    Such an attack would cause all packets, for both on-link and off-link destinations, to go to the rogue router. That router can then selectively examine, modify, or drop all packets sent on the link.
    RFC 4861 · Section 11.1(新しいタブで開きます)
  • イ(正解): RA ガードは,ルータを接続したポート以外で受信した RA を遮断する
    With this small static setup, the only interface forwarding RAs will be the pre-assigned router interface, while the non-router interfaces block all RAs.
    RFC 6105 · Section 3(新しいタブで開きます)
  • ア: デフォルトルータは DHCPv6 ではなく RA で設定される(DHCPv6 のデフォルトルータのオプションは提案段階)。問題文で DHCPv6 は使用していないとしている
    Even with such options added to DHCPv6, an RA is in principle still required to inform hosts to use DHCPv6.
    RFC 6104 · Section 3.10(新しいタブで開きます)
  • ウ: 偽の NA で変わるのは IP アドレスに対応するリンク層アドレスで,デフォルトルータのアドレス自体は変わらない
    Alternatively, the host can send a Neighbor Advertisement that includes a victim's IP address and its own link-layer address to overwrite an existing entry in the sender's destination cache, thereby forcing the sender to forward all of the victim's traffic to itself.
    RFC 4861 · Section 11.1(新しいタブで開きます)
  • エ: RS はルータに RA の送信を求めるメッセージで,ほかの PC のデフォルトルータを X にするものではない
    Router Solicitation: When an interface becomes enabled, hosts may send out Router Solicitations that request routers to generate Router Advertisements immediately rather than at their next scheduled time.
    RFC 4861 · Section 3(新しいタブで開きます)
問題 ID A2-SEC-0622 · AI 作成のオリジナル問題 · 正解と各選択肢の根拠を出典の原文で確認しています。 照合日 2026-11-08

非公式の学習用アプリです(IPA とは関係ありません)。問題はすべて AI が作成したオリジナルで、誤りを含む場合があります。